/[wait]/cvs-head/debian/rules
This is repository of my old source code which isn't updated any more. Go to git.rot13.org for current projects!
ViewVC logotype

Annotation of /cvs-head/debian/rules

Parent Directory Parent Directory | Revision Log Revision Log


Revision 44 - (hide annotations)
Fri Dec 29 12:29:27 2000 UTC (23 years, 5 months ago) by ulpfr
File size: 1750 byte(s)
First untested debian package generation.

1 ulpfr 44 #!/usr/bin/make -f
2     # Made with the aid of debmake, by Christoph Lameter,
3     # based on the sample debian/rules file for GNU hello by Ian Jackson.
4    
5     package=wait
6    
7     ifndef PERL
8     PERL = /usr/bin/perl
9     endif
10    
11     TMP =`pwd`/debian/tmp
12     archlib =`$(PERL) -MConfig -e 'print $$Config{installarchlib}'`
13     config =INSTALLDIRS=perl INSTALLMAN1DIR=$(TMP)/usr/share/man/man1 INSTALLMAN3DIR=$(TMP)/usr/share/man/man3 INSTALLPRIVLIB=$(TMP)/usr/lib/perl5 INSTALLARCHLIB=$(TMP)$(archlib) INSTALLSCRIPT=$(TMP)/usr/share/doc/wait/examples
14    
15     build:
16     $(checkdir)
17     $(PERL) Makefile.PL -default $(config)
18     make
19    
20     touch build
21    
22     clean:
23     $(checkdir)
24     -rm -f build c-config.h
25     -make distclean
26     -rm Makefile Makefile.old
27     -rm -f `find . -name "*~"`
28     -rm -f `find . -name "*.o"`
29     -rm -f `find . -name "*.so"`
30     -rm -rf debian/tmp debian/files* core debian/substvars blib
31    
32     binary-indep: checkroot build
33     $(checkdir)
34     # There are no architecture-independent files to be uploaded
35     # generated by this package. If there were any they would be
36     # made here.
37    
38     binary-arch: checkroot build
39     $(checkdir)
40     -rm -rf debian/tmp
41     install -d debian/tmp
42     cd debian/tmp && install -d `cat ../dirs`
43     rm -rf blib/man1
44     $(MAKE) pure_install
45     # Must have debmake installed for this to work. Otherwise please copy
46     # /usr/bin/debstd into the debian directory and change debstd to debian/debstd
47     #cp -p demo gdc `pwd`/debian/tmp/usr/share/doc/$(package)
48     dh_perl
49     debstd README
50     dpkg-gencontrol
51     #chown -R root.root debian/tmp
52     chmod -R u=rwX,go=rX debian/tmp
53     dpkg --build debian/tmp ..
54    
55     define checkdir
56     test -f debian/rules
57     endef
58    
59     # Below here is fairly generic really
60    
61     binary: binary-indep binary-arch
62    
63     checkroot:
64     $(checkdir)
65     #test root = "`whoami`"
66    
67     .PHONY: binary binary-arch binary-indep clean checkroot

Properties

Name Value
cvs2svn:cvs-rev 1.1
svn:executable *

  ViewVC Help
Powered by ViewVC 1.1.26